aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2023-10-05 21:43:19 -0700
committerChris Robinson <[email protected]>2023-10-06 00:33:48 -0700
commit6a70a30ca1ca1f0d0397ef9e6a9817b0f6cba079 (patch)
tree4f8c96d1c0fabdbe8107893961245b421f44705a /CMakeLists.txt
parent28ebc90521ca36fce35ea3e298938f2b35a8d79d (diff)
Include a copy of PFFFT
This is a notably faster FFT implementation for 32-bit float signals, provided under a 3-clause BSD license.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e0b6298f..94c22a52 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -631,6 +631,8 @@ set(COMMON_OBJS
common/dynload.h
common/intrusive_ptr.h
common/opthelpers.h
+ common/pffft.cpp
+ common/pffft.h
common/phase_shifter.h
common/polyphase_resampler.cpp
common/polyphase_resampler.h