aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2023-05-30 21:16:41 -0700
committerChris Robinson <[email protected]>2023-05-30 21:16:41 -0700
commit517bb94c0953de768f6aacca45456fd63bb2c96d (patch)
tree28852929ea0c61e1e7ad6f20233c861c5ae3f040 /CMakeLists.txt
parent2e75909ce90027267775d53e997d4936d6ef31a5 (diff)
Add a callback to report system device changes
Devices being added or removed, or the default device changing. Not all backends report this (none do currently), but it'll be supported where it can.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0bc8f2e2..e1c6db76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -813,6 +813,8 @@ set(ALC_OBJS
alc/effects/pshifter.cpp
alc/effects/reverb.cpp
alc/effects/vmorpher.cpp
+ alc/events.cpp
+ alc/events.h
alc/inprogext.h
alc/panning.cpp)