aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Robinson <[email protected]>2023-05-31 02:15:43 -0700
committerChris Robinson <[email protected]>2023-05-31 02:15:43 -0700
commit1a583b016a7b5e22f370e2f425722e3dc240a7dd (patch)
tree01febd72233b1845044c7c55ad04a4e01a614608 /CMakeLists.txt
parent23f90b854a51eeaf6f70383beeef42944b675ce0 (diff)
Initialize the WASAPI device helper earlier
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 8 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 02bf81b4..ae21a83e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1061,11 +1061,11 @@ if(WIN32)
set(BACKENDS "${BACKENDS} WASAPI,")
set(ALC_OBJS ${ALC_OBJS} alc/backends/wasapi.cpp alc/backends/wasapi.h)
if(ALSOFT_UWP)
- set_source_files_properties(alc/backends/wasapi.cpp alc/alconfig.cpp PROPERTIES COMPILE_FLAGS /ZW)
+ set_source_files_properties(alc/backends/wasapi.cpp alc/alconfig.cpp PROPERTIES COMPILE_FLAGS /ZW)
endif()
endif()
endif()
-
+
# Setup properly link flags for UWP
if(ALSOFT_UWP AND HAVE_WASAPI)
# Add compile and link flags required C++/CX
@@ -1416,8 +1416,8 @@ else()
endif()
target_link_libraries(${IMPL_TARGET} PRIVATE common ${LINKER_FLAGS} ${EXTRA_LIBS} ${MATH_LIB})
- if (WIN32)
- set_target_properties(${IMPL_TARGET} PROPERTIES
+ if(ALSOFT_UWP AND HAVE_WASAPI)
+ set_target_properties(${IMPL_TARGET} PROPERTIES
LINK_FLAGS_DEBUG "${LINKER_FLAGS_DEBUG}"
LINK_FLAGS_RELEASE "${LINKER_FLAGS_RELEASE}"
LINK_FLAGS_MINSIZEREL "${LINKER_FLAGS_RELEASE}"
@@ -1538,7 +1538,10 @@ if(FPMATH_SET)
message(STATUS "Building with SSE${FPMATH_SET} codegen")
message(STATUS "")
endif()
-
+if(ALSOFT_UWP)
+ message(STATUS "Building with UWP support")
+ message(STATUS "")
+endif()
if(ALSOFT_EAX)
message(STATUS "Building with legacy EAX extension support")
message(STATUS "")