aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Meyer <[email protected]>2012-08-07 23:11:28 +0200
committerThomas Meyer <[email protected]>2012-08-07 23:11:28 +0200
commitcbf4c1118d8f44453fefb8f2223b3a6fe743fa3f (patch)
tree1cd0d97bfdfe28b41e9d46232dbfc9b76c020de3 /Makefile.am
parent008a845efd9e3328c30878c49666e761ec512254 (diff)
Export only a minimum of symbols. This should fix PR472.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 16fa1c6..299215b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -270,6 +270,7 @@ $(PLUGIN_DIR)/%.o: $(PLUGIN_SRCDIR)/%.cc
$(GLIB_CFLAGS) \
$(GTK_CFLAGS) \
$(MOZILLA_CFLAGS) \
+ -fvisibility=hidden \
-fPIC -o $@ -c $<
$(PLUGIN_DIR)/$(BUILT_PLUGIN_LIBRARY): $(addprefix $(PLUGIN_DIR)/,$(PLUGIN_OBJECTS))
@@ -278,7 +279,7 @@ $(PLUGIN_DIR)/$(BUILT_PLUGIN_LIBRARY): $(addprefix $(PLUGIN_DIR)/,$(PLUGIN_OBJEC
$(PLUGIN_OBJECTS) \
$(GLIB_LIBS) \
$(GTK_LIBS) \
- $(MOZILLA_LIBS)\
+ $(MOZILLA_LIBS) \
-shared -o $@
clean-IcedTeaPlugin: