aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2020-10-20 00:00:57 +0200
committerSven Gothel <[email protected]>2020-10-20 00:00:57 +0200
commit28cbf05a872fd71b4e9d0a93fb4f8ad68e9d9b3b (patch)
tree29551978343be60400c8fcba70186c5a07373ccb /src/CMakeLists.txt
parenta78d2a6dcf97807ba5c74c12964e54ffa3bc93df (diff)
cmake: Drop all sub-folder CXX settings. Use root CMakeLists.txt global settings for all, avoiding confusion.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 98fe525..aed09e8 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -28,9 +28,6 @@ set_target_properties(
PROPERTIES
SOVERSION ${jaucpp_VERSION_MAJOR}
VERSION ${jaucpp_VERSION_STRING}
- CXX_STANDARD 17
- CXX_STANDARD_REQUIRED ON
- COMPILE_FLAGS "-Wall -Wextra -Werror"
)
install (DIRECTORY ${PROJECT_SOURCE_DIR}/include/jau/ DESTINATION include/jau)