aboutsummaryrefslogtreecommitdiffstats
path: root/java_net/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2021-01-25 09:50:27 +0100
committerSven Gothel <[email protected]>2021-01-25 09:50:27 +0100
commit0d276fd2a834206990cd81d36388015f21b4eee3 (patch)
treecdfee61aeecd78cfde0d06a8f761dc305c1dbde0 /java_net/CMakeLists.txt
parentc705b5bbc5ee842fb58089b7931be78dad726fad (diff)
java: install single jaulib_jar (next to jaulib_fat_jar) & java-source-zip; RELEASE: strip native libs, no java debug symbols.
Do not install java sub-modules jaulib_base, jaulib_jni, jaulib_net nor jaulib_pkg.
Diffstat (limited to 'java_net/CMakeLists.txt')
-rw-r--r--java_net/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/java_net/CMakeLists.txt b/java_net/CMakeLists.txt
index c1c2ac1..85248bc 100644
--- a/java_net/CMakeLists.txt
+++ b/java_net/CMakeLists.txt
@@ -14,7 +14,5 @@ add_dependencies(jaulib_net_jar jaulib_base_jar jaulib_jni_jar)
#add_dependencies(jaulib_pkg_jar jaulib_base_jar jaulib_jni_jar jaulib_net_jar)
set(JNI_HEADER_PATH "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_FILES_DIRECTORY}/jaulib_net_jar.dir/jni")
-install (FILES ${CMAKE_CURRENT_BINARY_DIR}/jaulib_net.jar DESTINATION ${CMAKE_INSTALL_LIBDIR}/../lib/java)
-
-# add_subdirectory (jni)
+# install (FILES ${CMAKE_CURRENT_BINARY_DIR}/jaulib_net.jar DESTINATION ${CMAKE_INSTALL_LIBDIR}/../lib/java)