aboutsummaryrefslogtreecommitdiffstats
path: root/trial/java/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2022-05-03 13:32:47 +0200
committerSven Gothel <[email protected]>2022-05-03 13:32:47 +0200
commit8446abc7f7c3fb4eadff9bd1870e45bfce3c4965 (patch)
tree861cf22006f7bdddb192552267124839260ef615 /trial/java/CMakeLists.txt
parentb670cbc538f5a7b6c6bd13089ea2a751800a0719 (diff)
Trial Unit Test C++: Working State; Completed dbt_client_server1x.cpp ...
Native trials match the java trial. Passed native and java tests alike, i.e. may fail w/ BT5 on SC0 or SC1 if no keys are delivered (known issue). Add counting successful protocol sessions next to the total, client determined and send to server via GattCmd. protocolSessionCount allows multiple connection and protocol sessions within one instance, which allows for further stability and leak (valgrind) testing later on. Each tests class's 1st test uses 1 protocolSession, where the 2nd test uses 2 protocolSessions. timeout is detected by the waiting loop thread. max_connection per protocolSession is 5 and shall help with analyzing the known BT5 lack of key delivery. Further renamed the test class numbers to match the test suffix number better.
Diffstat (limited to 'trial/java/CMakeLists.txt')
-rw-r--r--trial/java/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/trial/java/CMakeLists.txt b/trial/java/CMakeLists.txt
index 9d49ed7b..3d2b31a7 100644
--- a/trial/java/CMakeLists.txt
+++ b/trial/java/CMakeLists.txt
@@ -33,6 +33,6 @@ set( TARGETS_IDIOMATIC_EXAMPLES ${BASENAMES_IDIOMATIC_EXAMPLES} )
foreach(name ${TARGETS_IDIOMATIC_EXAMPLES})
add_test (NAME ${name} COMMAND sudo /sbin/capsh --caps=cap_net_raw,cap_net_admin+eip\ cap_setpcap,cap_setuid,cap_setgid+ep
--keep=1 --user=$ENV{USER} --addamb=cap_net_raw,cap_net_admin+eip
- -- -c "ulimit -c unlimited; $EXE_WRAPPER ${JAVA_RUNTIME} -cp ${JUNIT_JAR}:${direct_bt_jar_file}:${jaulib_base_jar_file}:${jaulib_test_jar_file}:${direct_bt_trial_jar_file} -Djava.library.path=${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR} org.junit.runner.JUnitCore ${name}")
+ -- -c "ulimit -c unlimited; ${JAVA_RUNTIME} -cp ${JUNIT_JAR}:${direct_bt_jar_file}:${jaulib_base_jar_file}:${jaulib_test_jar_file}:${direct_bt_trial_jar_file} -Djava.library.path=${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR} org.junit.runner.JUnitCore ${name}")
endforeach()