aboutsummaryrefslogtreecommitdiffstats
path: root/trial/java/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2022-04-18 04:19:14 +0200
committerSven Gothel <[email protected]>2022-04-18 04:19:14 +0200
commit8100b5179dd59354149eb606549515996bf23747 (patch)
tree35e54f7073997bfe39b046dcc4a02db3958f1c90 /trial/java/CMakeLists.txt
parentf1fad65ca999104bf30ef0110d69ba9ff8dd60ba (diff)
Run java trial w/o fat-jar package but dedicated native lib path to support gdb core dump debugging to locate the native libraries
Diffstat (limited to 'trial/java/CMakeLists.txt')
-rw-r--r--trial/java/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/trial/java/CMakeLists.txt b/trial/java/CMakeLists.txt
index a379be4b..7484c9d2 100644
--- a/trial/java/CMakeLists.txt
+++ b/trial/java/CMakeLists.txt
@@ -33,7 +33,6 @@ set( TARGETS_IDIOMATIC_EXAMPLES ${BASENAMES_IDIOMATIC_EXAMPLES} )
foreach(name ${TARGETS_IDIOMATIC_EXAMPLES})
add_test (NAME ${name} COMMAND sudo /sbin/capsh --caps=cap_net_raw,cap_net_admin+eip\ cap_setpcap,cap_setuid,cap_setgid+ep
--keep=1 --user=$ENV{USER} --addamb=cap_net_raw,cap_net_admin+eip
- -- -c "ulimit -c unlimited; $EXE_WRAPPER ${JAVA_RUNTIME} -cp ${JUNIT_JAR}:${direct_bt_fat_jar_file}:${jaulib_test_jar_file}:${direct_bt_trial_jar_file} org.junit.runner.JUnitCore ${name}")
+ -- -c "ulimit -c unlimited; $EXE_WRAPPER ${JAVA_RUNTIME} -cp ${JUNIT_JAR}:${jaulib_jar_file}:${direct_bt_jar_file}:${jaulib_test_jar_file}:${direct_bt_trial_jar_file} -Djava.library.path=${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR} org.junit.runner.JUnitCore ${name}")
endforeach()
-