summaryrefslogtreecommitdiffstats
path: root/pkg/linux/debian
diff options
context:
space:
mode:
authorJohn Stebbins <[email protected]>2015-11-09 08:10:22 -0800
committerJohn Stebbins <[email protected]>2015-11-09 08:10:22 -0800
commitaadfe93eb653c6ba99eaadcb68e6de523e4d60f6 (patch)
tree93f949459aff83db20d13d302a2e036338d34fbe /pkg/linux/debian
parentca28edf93c380f3133444d5861a771206007fbd5 (diff)
LinGui: add Ubuntu 15.10 Wily to nightly builds
Diffstat (limited to 'pkg/linux/debian')
-rw-r--r--pkg/linux/debian/control.wily30
-rwxr-xr-xpkg/linux/debian/rules.wily85
2 files changed, 115 insertions, 0 deletions
diff --git a/pkg/linux/debian/control.wily b/pkg/linux/debian/control.wily
new file mode 100644
index 000000000..04a588ae9
--- /dev/null
+++ b/pkg/linux/debian/control.wily
@@ -0,0 +1,30 @@
+Source: handbrake
+Section: graphics
+Priority: optional
+Maintainer: John Stebbins <[email protected]>
+Build-Depends: debhelper (>= 6), autotools-dev, libtool, libtool-bin, libgudev-1.0-dev, intltool, autoconf, yasm (>= 1.2.0), cmake, libbz2-dev, zlib1g-dev, libgtk-3-dev, libwebkitgtk-3.0-dev, libnotify-dev, libgstreamer1.0-dev, libgstreamer-plugins-base1.0-dev, wget, python (>= 2.6), libappindicator3-dev, libfribidi-dev (>= 0.19.0), libxml2-dev, libogg-dev, libtheora-dev, libvorbis-dev, libsamplerate0-dev, libfreetype6-dev, libfontconfig1-dev, libass-dev, libmp3lame-dev, libx264-dev, libjansson-dev
+Standards-Version: 3.8.4
+Homepage: http://www.handbrake.fr/
+
+Package: handbrake-cli
+Architecture: i386 amd64
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Conflicts: handbrake
+Description: versatile DVD ripper and video transcoder - command line
+ HandBrake is a versatile, easy-to-use tool for converting DVDs and other videos
+ into H.264, MPEG-4, or OGG formatted media. It's particularly useful for making
+ videos that are compatible with portable video devices such as the Apple
+ iPod/iPhone. This package contains the command-line variant,
+ HandBrakeCLI
+
+Package: handbrake-gtk
+Architecture: i386 amd64
+Depends: ${shlibs:Depends}, ${misc:Depends}, gstreamer1.0-libav, gstreamer1.0-plugins-base, gstreamer1.0-plugins-good, gstreamer1.0-plugins-bad, gstreamer1.0-plugins-ugly, gstreamer1.0-pulseaudio
+Conflicts: handbrake
+Description: versatile DVD ripper and video transcoder - GTK GUI
+ HandBrake is a versatile, easy-to-use tool for converting DVDs and other videos
+ into H.264, MPEG-4, or OGG formatted media. It's particularly useful for making
+ videos that are compatible with portable video devices such as the Apple
+ iPod/iPhone. This package contains the graphical variant, ghb.
+
+
diff --git a/pkg/linux/debian/rules.wily b/pkg/linux/debian/rules.wily
new file mode 100755
index 000000000..bab615cfe
--- /dev/null
+++ b/pkg/linux/debian/rules.wily
@@ -0,0 +1,85 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+ifneq ($(DEB_HOST_GNU_TYPE),$(DEB_BUILD_GNU_TYPE))
+CROSS= --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
+else
+CROSS= --build $(DEB_BUILD_GNU_TYPE)
+endif
+
+PKGDESTDIR = ../
+CONFIGURE = ./configure
+BUILDDIR = build
+FORCEVERSION =
+
+$(BUILDDIR)/GNUmakefile: $(CONFIGURE)
+ dh_testdir
+ unset CFLAGS; unset CPPLAGS; unset CXXLAGS; $(CONFIGURE) --disable-gtk-update-checks --prefix=/usr
+
+build: $(BUILDDIR)/GNUmakefile
+ dh_testdir
+ #We must build both the main project and the GTK project
+ unset CFLAGS ; unset CPPLAGS ; unset CXXLAGS; $(MAKE) -C $(BUILDDIR)
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_installdirs
+ $(MAKE) -C $(BUILDDIR) DESTDIR=$(CURDIR)/debian/tmp install
+
+# Build architecture-independent files here.
+binary-indep: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs -i
+ dh_installdocs -i
+ dh_install --sourcedir=debian/tmp -i
+ dh_icons -i
+ dh_link -i
+ dh_compress -i
+ dh_fixperms -i
+ dh_installdeb -i
+ dh_gencontrol -i $(FORCEVERSION)
+ dh_md5sums -i
+ dh_builddeb --destdir=$(PKGDESTDIR) -i
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_install --sourcedir=debian/tmp -a
+ dh_installchangelogs -a
+ dh_installdocs -a
+ dh_installexamples -a
+ dh_installman -a
+ dh_link -a
+ dh_icons -a
+ dh_strip -a
+ dh_compress -a
+ dh_fixperms -a
+ dh_installdeb -a
+ dh_shlibdeps -a
+ dh_gencontrol -a $(FORCEVERSION)
+ dh_md5sums -a
+ dh_builddeb -a --destdir=$(PKGDESTDIR) -- -Zbzip2
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install