aboutsummaryrefslogtreecommitdiffstats
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2021-09-19 01:22:55 +0200
committerSven Gothel <[email protected]>2021-09-19 01:22:55 +0200
commit2de5f489b3d0194c8eed31ff26d3f059fe2ea14e (patch)
treed8bbc43c3e9c1fada26b1e6fc4380b2de3b10ac6 /test/CMakeLists.txt
parentc7173473ed59d5b32743c6fea834ba2c339b4b2f (diff)
Silence -Wformat-overflow warnings on catch2s' catch_amalgamated.cpp compilation
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 1a57ac3..12f3677 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -9,7 +9,7 @@ set (catch2_LIB_SRCS
add_library (catch2 STATIC ${catch2_LIB_SRCS})
if(CMAKE_COMPILER_IS_GNUCC)
-target_compile_options(catch2 PUBLIC "-Wno-error=format-overflow")
+target_compile_options(catch2 PUBLIC "-Wno-error=format-overflow" "-Wno-format-overflow")
endif(CMAKE_COMPILER_IS_GNUCC)
# install(TARGETS catch2 LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})