aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2020-10-20 05:52:29 +0200
committerSven Gothel <[email protected]>2020-10-20 05:52:29 +0200
commitd7c8b7e16e93375d46dbb5771c92bbc335361b1b (patch)
tree9259cb252e70be8ff9b5c103aef11b85c2ceacdb /CMakeLists.txt
parente431d2b869d7ef71de51ce352671a6f2aba31e2a (diff)
cmake: Add warning (=error): -Wshadow -Wtype-limits -Wsign-compare
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d12cefe..3369f57 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,7 +10,10 @@ set (CMAKE_CXX_STANDARD_REQUIRED ON)
# for all
set (CC_FLAGS_WARNING "-Wall -Wextra -Werror")
set (GCC_FLAGS_WARNING_FORMAT "-Wformat=2 -Wformat-overflow=2 -Wformat-nonliteral -Wformat-security -Wformat-signedness -Wformat-y2k")
-set (GCC_FLAGS_WARNING "-Wall -Wextra -Wcast-align=strict -Wnull-dereference -Winit-self ${GCC_FLAGS_WARNING_FORMAT} -Werror")
+set (GCC_FLAGS_WARNING "-Wall -Wextra -Wshadow -Wtype-limits -Wsign-compare -Wcast-align=strict -Wnull-dereference -Winit-self ${GCC_FLAGS_WARNING_FORMAT} -Werror")
+
+# too pedantic, but nice to check once in a while
+# set (DISABLED_CC_FLAGS_WARNING "-Wsign-conversion")
# debug only
set (GCC_FLAGS_STACK "-fstack-protector-strong -fstack-check")