aboutsummaryrefslogtreecommitdiffstats
path: root/test/direct_bt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/direct_bt/CMakeLists.txt')
-rw-r--r--test/direct_bt/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/test/direct_bt/CMakeLists.txt b/test/direct_bt/CMakeLists.txt
index a96a41cd..c030615b 100644
--- a/test/direct_bt/CMakeLists.txt
+++ b/test/direct_bt/CMakeLists.txt
@@ -12,6 +12,8 @@ set( TARGETS_IDIOMATIC_EXAMPLES ${BASENAMES_IDIOMATIC_EXAMPLES} )
foreach( name ${TARGETS_IDIOMATIC_EXAMPLES} )
add_executable(${name} ${name}.cpp)
+ target_compile_options(${name} PUBLIC ${direct_bt_CXX_FLAGS})
+ target_link_options(${name} PUBLIC ${direct_bt_EXE_LINKER_FLAGS})
target_link_libraries(${name} direct_bt catch2)
add_dependencies(${name} direct_bt catch2)
add_test (NAME ${name} COMMAND ${name})