summaryrefslogtreecommitdiffstats
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
new file mode 100644
index 00000000..d6995c28
--- /dev/null
+++ b/examples/CMakeLists.txt
@@ -0,0 +1,16 @@
+include_directories(
+ ${tinyb_LIB_INCLUDE_DIRS}
+ ${GLIB2_INCLUDE_DIRS}
+ ${GIO_INCLUDE_DIRS}
+ ${GIO-UNIX_INCLUDE_DIRS}
+)
+
+
+add_executable (hellotinyb hellotinyb.cpp)
+set_target_properties(hellotinyb
+ PROPERTIES
+ CXX_STANDARD 11)
+
+include_directories(${PROJECT_SOURCE_DIR}/api)
+
+target_link_libraries (hellotinyb tinyb)