summaryrefslogtreecommitdiffstats
path: root/src/direct_bt/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2020-08-24 05:33:27 +0200
committerSven Gothel <[email protected]>2020-08-24 05:33:27 +0200
commitc1e543aacebd4c769abf4d6415c63d1a7ee6809d (patch)
tree7f7dc38fe61ca83406a2fda3956933e59cf32a64 /src/direct_bt/CMakeLists.txt
parent790e705aa16f47effd1db6e58a84123b9e357c9f (diff)
BluetoothFactory/DBTEnv: Pass JVM properties to environment, access DEBUG, VERBOSE via lazy DBTEnv from C++ (
DEBUG := environment 'direct_bt_debug' or JVM property 'direct_bt.debug' VERBOSE := environment 'direct_bt_verbose' or JVM property 'direct_bt.verbose' This changes allows passing JVM properties as C++ environment variables, to be accessed via DBTEnv. JVM property names are renamed from 'foo.bar' to 'jvm_foo_bar' and can be queried via 'DBTEnv::getProperty("foo_bar")' as it will also attempt the 'jvm_' prefix if the plain name wasn't resolved. The singleton DBTEnv instance can be retrieved via DBTEnv::get(), which allows lazy initialization of DEBUG, VERBOSE from environment variables. This is required, as the JVM loads the native libraries first, initializes all native static variables and only then can pass the properties to the native environment via POSIX 'setenv(..)'. Hence users should never use static initialization from native code in such cases, otherwise they can't benefit from the unified JVM properties.
Diffstat (limited to 'src/direct_bt/CMakeLists.txt')
-rw-r--r--src/direct_bt/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/direct_bt/CMakeLists.txt b/src/direct_bt/CMakeLists.txt
index b28ada5f..be1b6dba 100644
--- a/src/direct_bt/CMakeLists.txt
+++ b/src/direct_bt/CMakeLists.txt
@@ -12,8 +12,8 @@ include_directories(
set (direct_bt_LIB_SRCS
${PROJECT_SOURCE_DIR}/src/direct_bt/dfa_utf8_decode.cpp
${PROJECT_SOURCE_DIR}/src/direct_bt/DBTEnv.cpp
- ${PROJECT_SOURCE_DIR}/src/ieee11073/DataTypes.cpp
${PROJECT_SOURCE_DIR}/src/direct_bt/BasicTypes.cpp
+ ${PROJECT_SOURCE_DIR}/src/ieee11073/DataTypes.cpp
${PROJECT_SOURCE_DIR}/src/direct_bt/UUID.cpp
${PROJECT_SOURCE_DIR}/src/direct_bt/BTTypes.cpp
${PROJECT_SOURCE_DIR}/src/direct_bt/HCIComm.cpp