summaryrefslogtreecommitdiffstats
path: root/java/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2020-08-25 05:22:57 +0200
committerSven Gothel <[email protected]>2020-08-25 05:22:57 +0200
commitd3fcf4948480b9ab7f426cf54475e54aee1ce79b (patch)
tree2229f0d762b0582ae15ffd5d8746f507ea8d03a7 /java/CMakeLists.txt
parent2d6c05f88c379f9091d291aad90fc03e4ea10b33 (diff)
cmake: Add variable/define 'SKIP_TINYB': Allow to not build the tinyb native library.
Building the native lib on slow systems becomes a burden, hence skip if not required.
Diffstat (limited to 'java/CMakeLists.txt')
-rw-r--r--java/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/java/CMakeLists.txt b/java/CMakeLists.txt
index ba7c017b..28b52821 100644
--- a/java/CMakeLists.txt
+++ b/java/CMakeLists.txt
@@ -28,4 +28,7 @@ set(JNI_HEADER_PATH "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_FILES_DIRECTORY}/tinybj
install (FILES ${CMAKE_CURRENT_BINARY_DIR}/tinyb2.jar DESTINATION ${CMAKE_INSTALL_LIBDIR}/../lib/java)
add_subdirectory (jni/direct_bt)
-add_subdirectory (jni/tinyb)
+
+if(NOT SKIP_TINYB)
+ add_subdirectory (jni/tinyb)
+endif()