summaryrefslogtreecommitdiffstats
path: root/examples/java/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2020-02-09 08:50:22 +0100
committerSven Gothel <[email protected]>2020-02-09 08:50:22 +0100
commit4f99bad3abcabb2c37ef6543ec5ed8467914cd53 (patch)
tree5848e3fdaa3ebc2acc6f6ca0abae517b0b6253a2 /examples/java/CMakeLists.txt
parent0c76e289ad011f1c616176a896da02e9b255275e (diff)
Java Refactory: Expose intefaces via org.tinyb.* and D-Bus implementation via tinyb.dbus.*
Allows alternative interface implementations and delegated wrapper implementations for debug and tracing. Original D-Bus implementation can be retrieved via: 'BluetoothManager org.tinyb.BluetoothFactory.getDBusBluetoothManager()' A HCI native implementation will follow up w/o use of D-Bus. Otherwise the Java API is unchanged and this tinyb can replace previous implementation. Due to the major API change (despite interface is unchanged but BluetoothManager instantiation) the jar file has been renamed from 'tinyb.jar' to 'tinyb2.jar'. Same goes with the version number, which will be set to 'v2.0.0'. The native library and class definition is kept unchanged using the original names so far.
Diffstat (limited to 'examples/java/CMakeLists.txt')
-rw-r--r--examples/java/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/examples/java/CMakeLists.txt b/examples/java/CMakeLists.txt
index 4bfa5c58..07dbe4be 100644
--- a/examples/java/CMakeLists.txt
+++ b/examples/java/CMakeLists.txt
@@ -1,21 +1,21 @@
find_package(Java REQUIRED)
include(UseJava)
-add_jar(HelloTinyB SOURCES HelloTinyB.java INCLUDE_JARS "${CMAKE_CURRENT_BINARY_DIR}/../../java/tinyb.jar" ENTRY_POINT HelloTinyB)
+add_jar(HelloTinyB SOURCES HelloTinyB.java INCLUDE_JARS "${CMAKE_CURRENT_BINARY_DIR}/../../java/tinyb2.jar" ENTRY_POINT HelloTinyB)
add_custom_command(TARGET HelloTinyB
POST_BUILD
COMMAND cp "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_FILES_DIRECTORY}/HelloTinyB.dir/HelloTinyB.class" "${CMAKE_CURRENT_BINARY_DIR}"
)
-add_jar(AsyncTinyB SOURCES AsyncTinyB.java INCLUDE_JARS "${CMAKE_CURRENT_BINARY_DIR}/../../java/tinyb.jar" ENTRY_POINT AsyncTinyB)
+add_jar(AsyncTinyB SOURCES AsyncTinyB.java INCLUDE_JARS "${CMAKE_CURRENT_BINARY_DIR}/../../java/tinyb2.jar" ENTRY_POINT AsyncTinyB)
add_custom_command(TARGET AsyncTinyB
POST_BUILD
COMMAND cp "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_FILES_DIRECTORY}/AsyncTinyB.dir/AsyncTinyB.class" "${CMAKE_CURRENT_BINARY_DIR}"
)
-add_jar(Notification SOURCES Notification.java INCLUDE_JARS "${CMAKE_CURRENT_BINARY_DIR}/../../java/tinyb.jar" ENTRY_POINT Notification)
+add_jar(Notification SOURCES Notification.java INCLUDE_JARS "${CMAKE_CURRENT_BINARY_DIR}/../../java/tinyb2.jar" ENTRY_POINT Notification)
add_custom_command(TARGET Notification
POST_BUILD