summaryrefslogtreecommitdiffstats
path: root/examples/java/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2020-06-18 06:48:14 +0200
committerSven Gothel <[email protected]>2020-06-18 06:48:14 +0200
commit0ce725700a4e26e65f578fd1b1800d0bf85e289e (patch)
treebc7bdcf169d589cd13c0b10717bbaa9ea0a515eb /examples/java/CMakeLists.txt
parentb1126329e0bf84bb583027ca18b5e0e2a191e90e (diff)
Add debugging tool ScannerTinyB02; ScannerTinyB01 adds any device option.
Diffstat (limited to 'examples/java/CMakeLists.txt')
-rw-r--r--examples/java/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/examples/java/CMakeLists.txt b/examples/java/CMakeLists.txt
index 17f3045e..3956a103 100644
--- a/examples/java/CMakeLists.txt
+++ b/examples/java/CMakeLists.txt
@@ -36,6 +36,13 @@ add_custom_command(TARGET ScannerTinyB01
COMMAND cp "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_FILES_DIRECTORY}/ScannerTinyB01.dir/ScannerTinyB01.class" "${CMAKE_CURRENT_BINARY_DIR}"
)
+add_jar(ScannerTinyB02 SOURCES ScannerTinyB02.java INCLUDE_JARS "${CMAKE_CURRENT_BINARY_DIR}/../../java/tinyb2.jar" ENTRY_POINT Notification)
+
+add_custom_command(TARGET ScannerTinyB02
+ POST_BUILD
+ COMMAND cp "${CMAKE_CURRENT_BINARY_DIR}/${CMAKE_FILES_DIRECTORY}/ScannerTinyB02.dir/ScannerTinyB02.class" "${CMAKE_CURRENT_BINARY_DIR}"
+)
+
add_jar(ScannerTinyB10 SOURCES ScannerTinyB10.java INCLUDE_JARS "${CMAKE_CURRENT_BINARY_DIR}/../../java/tinyb2.jar" ENTRY_POINT Notification)
add_custom_command(TARGET ScannerTinyB10