summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlan <[email protected]>2016-05-05 15:23:53 +0200
committerPetre Eftime <[email protected]>2016-05-05 18:01:52 +0300
commit4f79c8d481119f8fa3e63f77286faddbeadb2b3c (patch)
treeee62b4c07015c83f05e480c1172db3dc2e53715c /CMakeLists.txt
parent4e82f20a5d1a7aff80e03bec5770bb27190498eb (diff)
Add OSGI manifest metadata
Added OSGI metadata to the manifest, so the library can be deployed in OSGI environments. The headers where first generated with the bnd tool, then manually copied inside the manifest template file with the appropriate variable substitutions. Also added a timestamp variable (BUILD_TSTAMP) in the main CmakeLists.txt for use in the manifest file (and elsewhere, if needed). Signed-off-by: Alan Alberghini <[email protected]> [closes #23]
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 65c64524..6412638d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,7 @@ string (REGEX REPLACE "^v[0-9]+\\.[0-9]+\\.[0-9]+\\-([0-9]+).*" "\\1" VERSION_CO
string (REGEX REPLACE "^v[0-9]+\\.[0-9]+\\.[0-9]+-[0-9]+\\-(.*)" "\\1" VERSION_SHA1 "${VERSION}")
set (VERSION_SHORT "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}")
set (VERSION_API "${VERSION_MAJOR}.${VERSION_MINOR}")
+string(TIMESTAMP BUILD_TSTAMP "%Y-%m-%d %H:%M:%S")
if ("${VERSION_COMMIT}" MATCHES "^v.*")
set (VERSION_COMMIT "")