summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSven Gothel <[email protected]>2020-08-25 06:13:34 +0200
committerSven Gothel <[email protected]>2020-08-25 06:13:34 +0200
commit312aa3d0b3ffef35905a55418a928760f7031b3c (patch)
tree02a831caded053f377dbd5bf9b8dd7174ec31e8d /CMakeLists.txt
parenta6e68f1f2a70ffbc55f6da60fac3767db550e3b1 (diff)
cmake: CMAKE_EXE_LINKER_FLAGS += '-latomic' to fix gcc-8 on Raspberry: undefined reference to `__atomic_store_8'
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 776b18f1..69fa091b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,10 @@ PKG_CHECK_MODULES (GIO-UNIX REQUIRED gio-unix-2.0>=2.40)
set (CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Wall -Wextra -fno-omit-frame-pointer -DDEBUG")
set (CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -Wall")
+
+# Required using gcc-8 on Raspberry ... to avoid: undefined reference to `__atomic_store_8'
+set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -latomic")
+
set (LIB_INSTALL_DIR "lib${LIB_SUFFIX}" CACHE PATH "Installation path for libraries")
# Set CMAKE_INSTALL_XXXDIR (XXX {BIN LIB ..} if not defined