summaryrefslogtreecommitdiffstats
path: root/man/man8/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/man8/Makefile.am')
-rw-r--r--man/man8/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/man/man8/Makefile.am b/man/man8/Makefile.am
index 366b4eb51..07f6aefa6 100644
--- a/man/man8/Makefile.am
+++ b/man/man8/Makefile.am
@@ -89,3 +89,13 @@ nodist_man_MANS = \
zfs-mount-generator.8
SUBSTFILES += $(nodist_man_MANS)
+
+if BUILD_LINUX
+# The man pager in most Linux distros defaults to BSD instead of Linux
+# when .Os is blank, but leaving it blank makes things a lot easier on
+# FreeBSD when OpenZFS is vendored in the base system.
+install-data-hook:
+ cd $(DESTDIR)$(mandir)/man8; \
+ $(SED) ${ac_inplace} -e 's/^\.Os$$/.Os Linux/' \
+ $(dist_man_MANS) $(nodist_man_MANS)
+endif