summaryrefslogtreecommitdiffstats
path: root/include/sys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/sys/Makefile.am')
-rw-r--r--include/sys/Makefile.am258
1 files changed, 129 insertions, 129 deletions
diff --git a/include/sys/Makefile.am b/include/sys/Makefile.am
index 17d78658c..f559f188e 100644
--- a/include/sys/Makefile.am
+++ b/include/sys/Makefile.am
@@ -1,137 +1,137 @@
SUBDIRS = fm fs crypto lua sysevent
COMMON_H = \
- $(top_srcdir)/include/sys/abd.h \
- $(top_srcdir)/include/sys/abd_impl.h \
- $(top_srcdir)/include/sys/aggsum.h \
- $(top_srcdir)/include/sys/arc.h \
- $(top_srcdir)/include/sys/arc_impl.h \
- $(top_srcdir)/include/sys/avl.h \
- $(top_srcdir)/include/sys/avl_impl.h \
- $(top_srcdir)/include/sys/bitops.h \
- $(top_srcdir)/include/sys/blkptr.h \
- $(top_srcdir)/include/sys/bplist.h \
- $(top_srcdir)/include/sys/bpobj.h \
- $(top_srcdir)/include/sys/bptree.h \
- $(top_srcdir)/include/sys/btree.h \
- $(top_srcdir)/include/sys/bqueue.h \
- $(top_srcdir)/include/sys/dataset_kstats.h \
- $(top_srcdir)/include/sys/dbuf.h \
- $(top_srcdir)/include/sys/ddt.h \
- $(top_srcdir)/include/sys/dmu.h \
- $(top_srcdir)/include/sys/dmu_impl.h \
- $(top_srcdir)/include/sys/dmu_objset.h \
- $(top_srcdir)/include/sys/dmu_recv.h \
- $(top_srcdir)/include/sys/dmu_redact.h \
- $(top_srcdir)/include/sys/dmu_send.h \
- $(top_srcdir)/include/sys/dmu_traverse.h \
- $(top_srcdir)/include/sys/dmu_tx.h \
- $(top_srcdir)/include/sys/dmu_zfetch.h \
- $(top_srcdir)/include/sys/dnode.h \
- $(top_srcdir)/include/sys/dsl_bookmark.h \
- $(top_srcdir)/include/sys/dsl_dataset.h \
- $(top_srcdir)/include/sys/dsl_deadlist.h \
- $(top_srcdir)/include/sys/dsl_deleg.h \
- $(top_srcdir)/include/sys/dsl_destroy.h \
- $(top_srcdir)/include/sys/dsl_dir.h \
- $(top_srcdir)/include/sys/dsl_crypt.h \
- $(top_srcdir)/include/sys/dsl_pool.h \
- $(top_srcdir)/include/sys/dsl_prop.h \
- $(top_srcdir)/include/sys/dsl_scan.h \
- $(top_srcdir)/include/sys/dsl_synctask.h \
- $(top_srcdir)/include/sys/dsl_userhold.h \
- $(top_srcdir)/include/sys/edonr.h \
- $(top_srcdir)/include/sys/efi_partition.h \
- $(top_srcdir)/include/sys/frame.h \
- $(top_srcdir)/include/sys/hkdf.h \
- $(top_srcdir)/include/sys/metaslab.h \
- $(top_srcdir)/include/sys/metaslab_impl.h \
- $(top_srcdir)/include/sys/mmp.h \
- $(top_srcdir)/include/sys/mntent.h \
- $(top_srcdir)/include/sys/mod.h \
- $(top_srcdir)/include/sys/multilist.h \
- $(top_srcdir)/include/sys/note.h \
- $(top_srcdir)/include/sys/nvpair.h \
- $(top_srcdir)/include/sys/nvpair_impl.h \
- $(top_srcdir)/include/sys/objlist.h \
- $(top_srcdir)/include/sys/pathname.h \
- $(top_srcdir)/include/sys/qat.h \
- $(top_srcdir)/include/sys/range_tree.h \
- $(top_srcdir)/include/sys/refcount.h \
- $(top_srcdir)/include/sys/rrwlock.h \
- $(top_srcdir)/include/sys/sa.h \
- $(top_srcdir)/include/sys/sa_impl.h \
- $(top_srcdir)/include/sys/skein.h \
- $(top_srcdir)/include/sys/spa_boot.h \
- $(top_srcdir)/include/sys/spa_checkpoint.h \
- $(top_srcdir)/include/sys/spa_log_spacemap.h \
- $(top_srcdir)/include/sys/space_map.h \
- $(top_srcdir)/include/sys/space_reftree.h \
- $(top_srcdir)/include/sys/spa.h \
- $(top_srcdir)/include/sys/spa_impl.h \
- $(top_srcdir)/include/sys/spa_checksum.h \
- $(top_srcdir)/include/sys/sysevent.h \
- $(top_srcdir)/include/sys/txg.h \
- $(top_srcdir)/include/sys/txg_impl.h \
- $(top_srcdir)/include/sys/u8_textprep_data.h \
- $(top_srcdir)/include/sys/u8_textprep.h \
- $(top_srcdir)/include/sys/uberblock.h \
- $(top_srcdir)/include/sys/uberblock_impl.h \
- $(top_srcdir)/include/sys/uio_impl.h \
- $(top_srcdir)/include/sys/unique.h \
- $(top_srcdir)/include/sys/uuid.h \
- $(top_srcdir)/include/sys/vdev_disk.h \
- $(top_srcdir)/include/sys/vdev_file.h \
- $(top_srcdir)/include/sys/vdev.h \
- $(top_srcdir)/include/sys/vdev_impl.h \
- $(top_srcdir)/include/sys/vdev_indirect_births.h \
- $(top_srcdir)/include/sys/vdev_indirect_mapping.h \
- $(top_srcdir)/include/sys/vdev_initialize.h \
- $(top_srcdir)/include/sys/vdev_raidz.h \
- $(top_srcdir)/include/sys/vdev_raidz_impl.h \
- $(top_srcdir)/include/sys/vdev_removal.h \
- $(top_srcdir)/include/sys/vdev_trim.h \
- $(top_srcdir)/include/sys/xvattr.h \
- $(top_srcdir)/include/sys/zap.h \
- $(top_srcdir)/include/sys/zap_impl.h \
- $(top_srcdir)/include/sys/zap_leaf.h \
- $(top_srcdir)/include/sys/zcp.h \
- $(top_srcdir)/include/sys/zcp_global.h \
- $(top_srcdir)/include/sys/zcp_iter.h \
- $(top_srcdir)/include/sys/zcp_prop.h \
- $(top_srcdir)/include/sys/zcp_set.h \
- $(top_srcdir)/include/sys/zfeature.h \
- $(top_srcdir)/include/sys/zfs_acl.h \
- $(top_srcdir)/include/sys/zfs_context.h \
- $(top_srcdir)/include/sys/zfs_debug.h \
- $(top_srcdir)/include/sys/zfs_delay.h \
- $(top_srcdir)/include/sys/zfs_file.h \
- $(top_srcdir)/include/sys/zfs_fuid.h \
- $(top_srcdir)/include/sys/zfs_project.h \
- $(top_srcdir)/include/sys/zfs_quota.h \
- $(top_srcdir)/include/sys/zfs_ratelimit.h \
- $(top_srcdir)/include/sys/zfs_rlock.h \
- $(top_srcdir)/include/sys/zfs_sa.h \
- $(top_srcdir)/include/sys/zfs_stat.h \
- $(top_srcdir)/include/sys/zfs_sysfs.h \
- $(top_srcdir)/include/sys/zfs_znode.h \
- $(top_srcdir)/include/sys/zil.h \
- $(top_srcdir)/include/sys/zil_impl.h \
- $(top_srcdir)/include/sys/zio_checksum.h \
- $(top_srcdir)/include/sys/zio_compress.h \
- $(top_srcdir)/include/sys/zio_crypt.h \
- $(top_srcdir)/include/sys/zio.h \
- $(top_srcdir)/include/sys/zio_impl.h \
- $(top_srcdir)/include/sys/zio_priority.h \
- $(top_srcdir)/include/sys/zrlock.h \
- $(top_srcdir)/include/sys/zthr.h
+ abd.h \
+ abd_impl.h \
+ aggsum.h \
+ arc.h \
+ arc_impl.h \
+ avl.h \
+ avl_impl.h \
+ bitops.h \
+ blkptr.h \
+ bplist.h \
+ bpobj.h \
+ bptree.h \
+ btree.h \
+ bqueue.h \
+ dataset_kstats.h \
+ dbuf.h \
+ ddt.h \
+ dmu.h \
+ dmu_impl.h \
+ dmu_objset.h \
+ dmu_recv.h \
+ dmu_redact.h \
+ dmu_send.h \
+ dmu_traverse.h \
+ dmu_tx.h \
+ dmu_zfetch.h \
+ dnode.h \
+ dsl_bookmark.h \
+ dsl_dataset.h \
+ dsl_deadlist.h \
+ dsl_deleg.h \
+ dsl_destroy.h \
+ dsl_dir.h \
+ dsl_crypt.h \
+ dsl_pool.h \
+ dsl_prop.h \
+ dsl_scan.h \
+ dsl_synctask.h \
+ dsl_userhold.h \
+ edonr.h \
+ efi_partition.h \
+ frame.h \
+ hkdf.h \
+ metaslab.h \
+ metaslab_impl.h \
+ mmp.h \
+ mntent.h \
+ mod.h \
+ multilist.h \
+ note.h \
+ nvpair.h \
+ nvpair_impl.h \
+ objlist.h \
+ pathname.h \
+ qat.h \
+ range_tree.h \
+ refcount.h \
+ rrwlock.h \
+ sa.h \
+ sa_impl.h \
+ skein.h \
+ spa_boot.h \
+ spa_checkpoint.h \
+ spa_log_spacemap.h \
+ space_map.h \
+ space_reftree.h \
+ spa.h \
+ spa_impl.h \
+ spa_checksum.h \
+ sysevent.h \
+ txg.h \
+ txg_impl.h \
+ u8_textprep_data.h \
+ u8_textprep.h \
+ uberblock.h \
+ uberblock_impl.h \
+ uio_impl.h \
+ unique.h \
+ uuid.h \
+ vdev_disk.h \
+ vdev_file.h \
+ vdev.h \
+ vdev_impl.h \
+ vdev_indirect_births.h \
+ vdev_indirect_mapping.h \
+ vdev_initialize.h \
+ vdev_raidz.h \
+ vdev_raidz_impl.h \
+ vdev_removal.h \
+ vdev_trim.h \
+ xvattr.h \
+ zap.h \
+ zap_impl.h \
+ zap_leaf.h \
+ zcp.h \
+ zcp_global.h \
+ zcp_iter.h \
+ zcp_prop.h \
+ zcp_set.h \
+ zfeature.h \
+ zfs_acl.h \
+ zfs_context.h \
+ zfs_debug.h \
+ zfs_delay.h \
+ zfs_file.h \
+ zfs_fuid.h \
+ zfs_project.h \
+ zfs_quota.h \
+ zfs_ratelimit.h \
+ zfs_rlock.h \
+ zfs_sa.h \
+ zfs_stat.h \
+ zfs_sysfs.h \
+ zfs_znode.h \
+ zil.h \
+ zil_impl.h \
+ zio_checksum.h \
+ zio_compress.h \
+ zio_crypt.h \
+ zio.h \
+ zio_impl.h \
+ zio_priority.h \
+ zrlock.h \
+ zthr.h
KERNEL_H = \
- $(top_srcdir)/include/sys/zfs_ioctl.h \
- $(top_srcdir)/include/sys/zfs_ioctl_impl.h \
- $(top_srcdir)/include/sys/zfs_onexit.h \
- $(top_srcdir)/include/sys/zvol.h \
- $(top_srcdir)/include/sys/zvol_impl.h
+ zfs_ioctl.h \
+ zfs_ioctl_impl.h \
+ zfs_onexit.h \
+ zvol.h \
+ zvol_impl.h
USER_H =