aboutsummaryrefslogtreecommitdiffstats
path: root/include/sharefs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/sharefs/Makefile.am')
-rw-r--r--include/sharefs/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/include/sharefs/Makefile.am b/include/sharefs/Makefile.am
new file mode 100644
index 000000000..b343c75b7
--- /dev/null
+++ b/include/sharefs/Makefile.am
@@ -0,0 +1,13 @@
+COMMON_H =
+
+KERNEL_H = \
+ $(top_srcdir)/include/sharefs/share.h
+
+USER_H =
+
+EXTRA_DIST = $(COMMON_H) $(KERNEL_H) $(USER_H)
+
+if CONFIG_KERNEL
+kerneldir = /usr/src/spl-$(SPL_META_VERSION)-$(SPL_META_RELEASE)/$(LINUX_VERSION)/sharefs
+kernel_HEADERS = $(KERNEL_H)
+endif