aboutsummaryrefslogtreecommitdiffstats
path: root/include/os/freebsd/zfs/sys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/os/freebsd/zfs/sys/Makefile.am')
-rw-r--r--include/os/freebsd/zfs/sys/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/include/os/freebsd/zfs/sys/Makefile.am b/include/os/freebsd/zfs/sys/Makefile.am
index 56c0f6e90..8a1f8b313 100644
--- a/include/os/freebsd/zfs/sys/Makefile.am
+++ b/include/os/freebsd/zfs/sys/Makefile.am
@@ -11,4 +11,7 @@ KERNEL_H = \
zfs_znode_impl.h \
zpl.h
-EXTRA_DIST = $(KERNEL_H)
+if CONFIG_KERNEL
+kerneldir = @prefix@/src/zfs-$(VERSION)/include/sys
+kernel_HEADERS = $(KERNEL_H)
+endif