aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 6ed7cdad8..64d9fa29e 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -16,8 +16,13 @@ noinst_HEADERS += vm/*.h
install-data-local:
destname=spl-$(SPL_META_VERSION)/$(LINUX_VERSION); \
- instdest=$(DESTDIR)/${prefix}/src/$$destname; \
+ instdest=$(DESTDIR)/usr/src/$$destname; \
instfiles=`find . -name '*.h'`; \
for instfile in $$instfiles; do \
$(INSTALL) -D $$instfile $$instdest/$$instfile; \
done
+
+uninstall-local:
+ destname=spl-$(SPL_META_VERSION)/$(LINUX_VERSION); \
+ instdest=$(DESTDIR)/usr/src/$$destname; \
+ $(RM) -R $$instdest