aboutsummaryrefslogtreecommitdiffstats
path: root/contrib/pyzfs/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/pyzfs/setup.py')
-rw-r--r--contrib/pyzfs/setup.py19
1 files changed, 17 insertions, 2 deletions
diff --git a/contrib/pyzfs/setup.py b/contrib/pyzfs/setup.py
index f86f3c1bd..3baa25c1b 100644
--- a/contrib/pyzfs/setup.py
+++ b/contrib/pyzfs/setup.py
@@ -1,10 +1,24 @@
-# Copyright 2015 ClusterHQ. See LICENSE file for details.
+#
+# Copyright 2015 ClusterHQ
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
from setuptools import setup, find_packages
setup(
name="pyzfs",
- version="0.2.3",
+ version="1.0.0",
description="Wrapper for libzfs_core",
author="ClusterHQ",
author_email="[email protected]",
@@ -33,6 +47,7 @@ setup(
setup_requires=[
"cffi",
],
+ python_requires='>=2.7,<3',
zip_safe=False,
test_suite="libzfs_core.test",
)