aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/zed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cmd/zed/Makefile.am')
-rw-r--r--cmd/zed/Makefile.am57
1 files changed, 2 insertions, 55 deletions
diff --git a/cmd/zed/Makefile.am b/cmd/zed/Makefile.am
index 9c11315f2..fb479f9b5 100644
--- a/cmd/zed/Makefile.am
+++ b/cmd/zed/Makefile.am
@@ -1,12 +1,11 @@
+SUBDIRS = zed.d
+
include $(top_srcdir)/config/Rules.am
DEFAULT_INCLUDES += \
-I$(top_srcdir)/include \
-I$(top_srcdir)/lib/libspl/include
-EXTRA_DIST = zed.d/README \
- zed.d/history_event-zfs-list-cacher.sh.in
-
sbin_PROGRAMS = zed
ZED_SRC = \
@@ -47,55 +46,3 @@ zed_LDADD = \
zed_LDADD += -lrt
zed_LDFLAGS = -pthread
-
-zedconfdir = $(sysconfdir)/zfs/zed.d
-
-dist_zedconf_DATA = \
- zed.d/zed-functions.sh \
- zed.d/zed.rc
-
-zedexecdir = $(zfsexecdir)/zed.d
-
-dist_zedexec_SCRIPTS = \
- zed.d/all-debug.sh \
- zed.d/all-syslog.sh \
- zed.d/data-notify.sh \
- zed.d/generic-notify.sh \
- zed.d/resilver_finish-notify.sh \
- zed.d/scrub_finish-notify.sh \
- zed.d/statechange-led.sh \
- zed.d/statechange-notify.sh \
- zed.d/vdev_clear-led.sh \
- zed.d/vdev_attach-led.sh \
- zed.d/pool_import-led.sh \
- zed.d/resilver_finish-start-scrub.sh
-
-nodist_zedexec_SCRIPTS = zed.d/history_event-zfs-list-cacher.sh
-
-$(nodist_zedexec_SCRIPTS): %: %.in
- -$(SED) -e 's,@bindir\@,$(bindir),g' \
- -e 's,@runstatedir\@,$(runstatedir),g' \
- -e 's,@sbindir\@,$(sbindir),g' \
- -e 's,@sysconfdir\@,$(sysconfdir),g' \
- $< >'$@'
-
-zedconfdefaults = \
- all-syslog.sh \
- data-notify.sh \
- resilver_finish-notify.sh \
- scrub_finish-notify.sh \
- statechange-led.sh \
- statechange-notify.sh \
- vdev_clear-led.sh \
- vdev_attach-led.sh \
- pool_import-led.sh \
- resilver_finish-start-scrub.sh
-
-install-data-hook:
- $(MKDIR_P) "$(DESTDIR)$(zedconfdir)"
- for f in $(zedconfdefaults); do \
- test -f "$(DESTDIR)$(zedconfdir)/$${f}" -o \
- -L "$(DESTDIR)$(zedconfdir)/$${f}" || \
- ln -s "$(zedexecdir)/$${f}" "$(DESTDIR)$(zedconfdir)"; \
- done
- chmod 0600 "$(DESTDIR)$(zedconfdir)/zed.rc"