aboutsummaryrefslogtreecommitdiffstats
path: root/cmd/zed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cmd/zed/Makefile.am')
-rw-r--r--cmd/zed/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/cmd/zed/Makefile.am b/cmd/zed/Makefile.am
index e9e38d8e5..9c11315f2 100644
--- a/cmd/zed/Makefile.am
+++ b/cmd/zed/Makefile.am
@@ -54,14 +54,13 @@ dist_zedconf_DATA = \
zed.d/zed-functions.sh \
zed.d/zed.rc
-zedexecdir = $(libexecdir)/zfs/zed.d
+zedexecdir = $(zfsexecdir)/zed.d
dist_zedexec_SCRIPTS = \
zed.d/all-debug.sh \
zed.d/all-syslog.sh \
zed.d/data-notify.sh \
zed.d/generic-notify.sh \
- zed.d/history_event-zfs-list-cacher.sh \
zed.d/resilver_finish-notify.sh \
zed.d/scrub_finish-notify.sh \
zed.d/statechange-led.sh \
@@ -71,7 +70,9 @@ dist_zedexec_SCRIPTS = \
zed.d/pool_import-led.sh \
zed.d/resilver_finish-start-scrub.sh
-zed.d/history_event-zfs-list-cacher.sh: %: %.in
+nodist_zedexec_SCRIPTS = zed.d/history_event-zfs-list-cacher.sh
+
+$(nodist_zedexec_SCRIPTS): %: %.in
-$(SED) -e 's,@bindir\@,$(bindir),g' \
-e 's,@runstatedir\@,$(runstatedir),g' \
-e 's,@sbindir\@,$(sbindir),g' \