summaryrefslogtreecommitdiffstats
path: root/cmd/dbufstat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'cmd/dbufstat/Makefile.am')
-rw-r--r--cmd/dbufstat/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/cmd/dbufstat/Makefile.am b/cmd/dbufstat/Makefile.am
index f3b7ed809..e672a01a4 100644
--- a/cmd/dbufstat/Makefile.am
+++ b/cmd/dbufstat/Makefile.am
@@ -1,13 +1,5 @@
-dist_bin_SCRIPTS = dbufstat
+include $(top_srcdir)/config/Substfiles.am
-#
-# The dbufstat script is compatible with both Python 2.6 and 3.4.
-# As such the python 3 shebang can be replaced at install time when
-# targeting a python 2 system. This allows us to maintain a single
-# version of the source.
-#
-if USING_PYTHON_2
-install-exec-hook:
- $(SED) ${ac_inplace} -e 's|^#!/usr/bin/env python3|#!/usr/bin/env python2|' \
- $(DESTDIR)$(bindir)/dbufstat
-endif
+bin_SCRIPTS = dbufstat
+
+SUBSTFILES += $(bin_SCRIPTS)