summaryrefslogtreecommitdiffstats
path: root/PKGBUILD-spl-modules.in
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD-spl-modules.in')
-rw-r--r--PKGBUILD-spl-modules.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD-spl-modules.in b/PKGBUILD-spl-modules.in
new file mode 100644
index 000000000..a04bd4fcf
--- /dev/null
+++ b/PKGBUILD-spl-modules.in
@@ -0,0 +1,23 @@
+# Maintainer: Prakash Surya <[email protected]>
+pkgname=@SPL_META_NAME@-modules
+pkgver=@SPL_META_VERSION@
+pkgrel=@SPL_META_RELEASE@
+pkgdesc="Contains kernel modules for emulating Solaris style primatives in the linux kernel."
+arch=(x86_64)
+url="git://github.com/zfsonlinux/spl.git"
+license=(@LICENSE@)
+source=(@SPL_META_NAME@-@[email protected])
+
+build() {
+ cd $srcdir/@SPL_META_NAME@-@SPL_META_VERSION@
+ ./configure --with-config=kernel \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib
+ make
+}
+
+package() {
+ cd $srcdir/@SPL_META_NAME@-@SPL_META_VERSION@
+ make DESTDIR=$pkgdir install
+}