summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c0b541cc..101b38ac3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -104,8 +104,9 @@ commitcheck:
fi
cstyle:
- @find ${top_srcdir} -name build -prune -o -name '*.[hc]' \
- ! -name 'zfs_config.*' ! -name '*.mod.c' -type f \
+ @find ${top_srcdir} -name build -prune -o -type f -name '*.[hc]' \
+ ! -name 'zfs_config.*' ! -name '*.mod.c' \
+ ! -name 'opt_global.h' ! -name '*_if*.h' \
-exec ${top_srcdir}/scripts/cstyle.pl -cpP {} \+
filter_executable = -exec test -x '{}' \; -print