summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 96ff7d860..840604c23 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -115,9 +115,11 @@ commitcheck:
PHONY += cstyle
cstyle:
- @find ${top_srcdir} -name build -prune -o -type f -name '*.[hc]' \
+ @find ${top_srcdir} -name build -prune \
+ -o -type f -name '*.[hc]' \
! -name 'zfs_config.*' ! -name '*.mod.c' \
! -name 'opt_global.h' ! -name '*_if*.h' \
+ ! -path './module/zstd/lib/*' \
-exec ${top_srcdir}/scripts/cstyle.pl -cpP {} \+
filter_executable = -exec test -x '{}' \; -print