summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e009212f4..2cd2aabc5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,11 +47,14 @@ cstyle:
shellcheck:
@if type shellcheck > /dev/null 2>&1; then \
- (find ${top_srcdir} -type f -name '*.sh.in' -o -type f \
- -name '*.sh'; find etc/init.d/zfs*.in -type f) | \
+ shellcheck --exclude=SC1090 --format gcc scripts/paxcheck.sh \
+ scripts/zloop.sh \
+ scripts/zfs-tests.sh \
+ scripts/zfs.sh; \
+ (find cmd/zed/zed.d/*.sh -type f) | \
grep -v 'zfs-script-config' | \
while read file; do \
- shellcheck --format gcc "$$file"; \
+ shellcheck --exclude=SC1090 --format gcc "$$file"; \
done; \
fi