aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 6 insertions, 8 deletions
diff --git a/Makefile.am b/Makefile.am
index 45474daa4..4e4625794 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,5 @@
ACLOCAL_AMFLAGS = -I config
-include config/rpm.am
-include config/deb.am
-include config/tgz.am
-
SUBDIRS = include
if BUILD_LINUX
SUBDIRS += rpm
@@ -54,6 +50,7 @@ EXTRA_DIST += module/zfs/THIRDPARTYLICENSE.cityhash.descrip
@CODE_COVERAGE_RULES@
GITREV = include/zfs_gitrev.h
+CLEANFILES = $(GITREV)
PHONY = gitrev
gitrev:
@@ -68,10 +65,7 @@ gitrev:
mv -f $(GITREV)~ $(GITREV); \
fi
-$(GITREV): gitrev
-
-BUILT_SOURCES = $(GITREV)
-CLEANFILES = $(GITREV)
+all: gitrev
# Double-colon rules are allowed; there are multiple independent definitions.
distclean-local::
@@ -252,4 +246,8 @@ pkg-dkms: @DEFAULT_PACKAGE@-dkms
pkg-kmod: @DEFAULT_PACKAGE@-kmod
pkg-utils: @DEFAULT_PACKAGE@-utils
+include config/rpm.am
+include config/deb.am
+include config/tgz.am
+
.PHONY: $(PHONY)