aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 43891af71..02e104434 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,7 +75,7 @@ install-data-hook:
ln -fs zfs.release spl.release
endif
-codecheck: cstyle shellcheck flake8 mancheck testscheck
+codecheck: cstyle shellcheck flake8 mancheck testscheck vcscheck
checkstyle: codecheck commitcheck
@@ -117,6 +117,12 @@ testscheck:
xargs -r stat -c '%A %n' | \
awk '{c++; print} END {if(c>0) exit 1}'
+vcscheck:
+ @if git rev-parse --git-dir > /dev/null 2>&1; then \
+ git ls-files . --exclude-standard --others | \
+ awk '{c++; print} END {if(c>0) exit 1}' ; \
+ fi
+
lint: cppcheck paxcheck
cppcheck: