summaryrefslogtreecommitdiffstats
path: root/udev/rules.d/Makefile.am
diff options
context:
space:
mode:
authorKyle Fuller <[email protected]>2011-08-05 20:22:58 +0100
committerBrian Behlendorf <[email protected]>2011-08-08 16:21:10 -0700
commit12d06bac9b22b11d8a322dfea4bdb50b106c254f (patch)
treed3014ec1f682731484091506966b2032d2396f8a /udev/rules.d/Makefile.am
parentf3ab88d6461dec46dea240763843f66300facfab (diff)
Move udev rules from /etc/udev to /lib/udev
This change moves the default install location for the zfs udev rules from /etc/udev/ to /lib/udev/. The correct convention is for rules provided by a package to be installed in /lib/udev/. The /etc/udev/ directory is reserved for custom rules or local overrides. Additionally, this patch cleans up some abuse of the bindir install location by adding a udevdir and udevruledir install directories. This allows us to revert to the default bin install location. The udev install directories can be set with the following new options. --with-udevdir=DIR install udev helpers [EPREFIX/lib/udev] --with-udevruledir=DIR install udev rules [UDEVDIR/rules.d] Signed-off-by: Brian Behlendorf <[email protected]> Closes #356
Diffstat (limited to 'udev/rules.d/Makefile.am')
-rw-r--r--udev/rules.d/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/udev/rules.d/Makefile.am b/udev/rules.d/Makefile.am
new file mode 100644
index 000000000..41740517e
--- /dev/null
+++ b/udev/rules.d/Makefile.am
@@ -0,0 +1,14 @@
+udevrule_DATA = \
+ 60-zpool.rules \
+ 60-zvol.rules
+
+EXTRA_DIST = \
+ 60-zpool.rules.in \
+ 60-zvol.rules.in
+
+$(udevrule_DATA):
+ -$(SED) -e 's,@udevdir\@,$(udevdir),g' '[email protected]' >'$@'
+
+distclean-local::
+ -$(RM) $(udevrule_DATA)
+