aboutsummaryrefslogtreecommitdiffstats
path: root/tests/zfs-tests/cmd/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2022-05-26 09:24:50 -0700
committerGitHub <[email protected]>2022-05-26 09:24:50 -0700
commitd98a67a53a180bd88ec8d9aeea75d92e1c9968b5 (patch)
tree622c9d577ad42f9cf3ac31003fc614adc003f9b2 /tests/zfs-tests/cmd/Makefile.am
parentb62829295e9529d1c321816a1027fac5afc7d6f5 (diff)
Replace EXTRA_DIST with dist_noinst_DATA
The EXTRA_DIST variable is ignored when used in the FALSE conditional of a Makefile.am. This results in the `make dist` target omitting these files from the generated tarball unless CONFIG_USER is defined. This issue can be avoided by switching to use the dist_noinst_DATA variable which is handled as expected by autoconf. This change also adds support for --with-config=dist as an alias for --with-config=srpm and updates the GitHub workflows to use it. Reviewed-by: Ahelenia ZiemiaƄska <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #13459 Closes #13505
Diffstat (limited to 'tests/zfs-tests/cmd/Makefile.am')
-rw-r--r--tests/zfs-tests/cmd/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/zfs-tests/cmd/Makefile.am b/tests/zfs-tests/cmd/Makefile.am
index 71edd4939..e3c9874dc 100644
--- a/tests/zfs-tests/cmd/Makefile.am
+++ b/tests/zfs-tests/cmd/Makefile.am
@@ -41,7 +41,7 @@ scripts_zfs_tests_bin_PROGRAMS += %D%/draid
libnvpair.la
%C%_draid_LDADD += $(ZLIB_LIBS)
-EXTRA_DIST += $(addprefix %D%/,file/file_common.h)
+dist_noinst_DATA += %D%/file/file_common.h
scripts_zfs_tests_bin_PROGRAMS += %D%/file_append %D%/file_check %D%/file_trunc %D%/file_write %D%/largest_file %D%/randwritecomp
%C%_file_append_SOURCES = %D%/file/file_append.c
%C%_file_check_SOURCES = %D%/file/file_check.c
@@ -116,7 +116,7 @@ scripts_zfs_tests_bin_PROGRAMS += %D%/xattrtest
scripts_zfs_tests_bin_PROGRAMS += %D%/zed_fd_spill-zedlet
-EXTRA_DIST += $(addprefix %D%/,linux_dos_attributes/dos_attributes.h)
+dist_noinst_DATA += %D%/linux_dos_attributes/dos_attributes.h
scripts_zfs_tests_bin_PROGRAMS += %D%/read_dos_attributes %D%/write_dos_attributes
%C%_read_dos_attributes_SOURCES = %D%/linux_dos_attributes/read_dos_attributes.c
%C%_write_dos_attributes_SOURCES = %D%/linux_dos_attributes/write_dos_attributes.c