aboutsummaryrefslogtreecommitdiffstats
path: root/tests/zfs-tests/cmd/Makefile.am
diff options
context:
space:
mode:
authorCedric Maunoury <[email protected]>2021-02-24 18:48:58 +0100
committerGitHub <[email protected]>2021-02-24 09:48:58 -0800
commitb9c07ec71b205c034e63f34fa3546437ea766b3b (patch)
tree1a3f800327f72bc444ab00e6e877b17a5ec6d884 /tests/zfs-tests/cmd/Makefile.am
parent9312e0fd1e162094ba2470408878879fa24eeaf7 (diff)
send_iterate_snap : doall send without fromsnap
The behavior of a NULL fromsnap was inadvertently changed for a doall send when the send/recv logic in libzfs was updated. Restore the previous behavior by correcting send_iterate_snap() to include all the snapshots in the nvlist for this case. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Cedric Maunoury <[email protected]> Closes #11608
Diffstat (limited to 'tests/zfs-tests/cmd/Makefile.am')
-rw-r--r--tests/zfs-tests/cmd/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/zfs-tests/cmd/Makefile.am b/tests/zfs-tests/cmd/Makefile.am
index 7fe9a2c57..2b965ca70 100644
--- a/tests/zfs-tests/cmd/Makefile.am
+++ b/tests/zfs-tests/cmd/Makefile.am
@@ -25,6 +25,7 @@ SUBDIRS = \
readmmap \
rename_dir \
rm_lnkcnt_zero_file \
+ send_doall \
stride_dd \
threadsappend