aboutsummaryrefslogtreecommitdiffstats
path: root/tests/zfs-tests/cmd/Makefile.am
diff options
context:
space:
mode:
authorMatthew Macy <[email protected]>2019-12-18 12:29:43 -0800
committerBrian Behlendorf <[email protected]>2019-12-18 12:29:43 -0800
commit7839c4b5e1e79e29f0df4ec9fe5e1e7182473e47 (patch)
treeef0214b6e757aeb181e54944abffe4e116bbf018 /tests/zfs-tests/cmd/Makefile.am
parent118fc3ef07c53a88ea1d4c21142a2b01c4648434 (diff)
Update ZTS to work on FreeBSD
Update the common ZTS scripts and individual test cases as needed in order to allow them to be run on FreeBSD. The high level goal is to provide compatibility wrappers whenever possible to minimize changes to individual test cases. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: John Kennedy <[email protected]> Signed-off-by: Matt Macy <[email protected]> Signed-off-by: Ryan Moeller <[email protected]> Closes #9692
Diffstat (limited to 'tests/zfs-tests/cmd/Makefile.am')
-rw-r--r--tests/zfs-tests/cmd/Makefile.am14
1 files changed, 9 insertions, 5 deletions
diff --git a/tests/zfs-tests/cmd/Makefile.am b/tests/zfs-tests/cmd/Makefile.am
index 09c59f591..934587b1a 100644
--- a/tests/zfs-tests/cmd/Makefile.am
+++ b/tests/zfs-tests/cmd/Makefile.am
@@ -2,7 +2,6 @@ EXTRA_DIST = file_common.h
SUBDIRS = \
chg_usr_exec \
- user_ns_exec \
devname2devid \
dir_rd_update \
file_check \
@@ -19,11 +18,16 @@ SUBDIRS = \
mmap_libaio \
mmapwrite \
nvlist_to_lua \
- randfree_file \
randwritecomp \
readmmap \
rename_dir \
rm_lnkcnt_zero_file \
- threadsappend \
- xattrtest \
- stride_dd
+ stride_dd \
+ threadsappend
+
+if BUILD_LINUX
+SUBDIRS += \
+ randfree_file \
+ user_ns_exec \
+ xattrtest
+endif