aboutsummaryrefslogtreecommitdiffstats
path: root/tests/runfiles/Makefile.am
diff options
context:
space:
mode:
authorTony Hutter <[email protected]>2018-04-06 16:34:21 -0700
committerBrian Behlendorf <[email protected]>2018-04-06 16:34:21 -0700
commit6c9af9e8f4a2901c9a5f205876b67dcc3216cbd8 (patch)
tree3661a51d97353707054e508a0171a26ec75d827b /tests/runfiles/Makefile.am
parent812323bb03ce4c31f61bfb83d70eb1f5c494df25 (diff)
Fix "file is executable, but no shebang" warnings
Fedora 28's RPM build checks warn when executable files don't have a shebang line. These warnings are caused when we (incorrectly) include data & config files in the_SCRIPTS automake lines. Files in _SCRIPTS are marked executable by automake. This patch fixes the issue by including non-executable scripts in a _DATA line instead. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Giuseppe Di Natale <[email protected]> Signed-off-by: Tony Hutter <[email protected]> Closes #7359 Closes #7395
Diffstat (limited to 'tests/runfiles/Makefile.am')
-rw-r--r--tests/runfiles/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/runfiles/Makefile.am b/tests/runfiles/Makefile.am
index cddfb2ed6..138d905a5 100644
--- a/tests/runfiles/Makefile.am
+++ b/tests/runfiles/Makefile.am
@@ -1,2 +1,2 @@
pkgdatadir = $(datadir)/@PACKAGE@/runfiles
-dist_pkgdata_SCRIPTS = *.run
+dist_pkgdata_DATA = *.run