aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2022-05-26 09:24:50 -0700
committerGitHub <[email protected]>2022-05-26 09:24:50 -0700
commitd98a67a53a180bd88ec8d9aeea75d92e1c9968b5 (patch)
tree622c9d577ad42f9cf3ac31003fc614adc003f9b2 /tests/Makefile.am
parentb62829295e9529d1c321816a1027fac5afc7d6f5 (diff)
Replace EXTRA_DIST with dist_noinst_DATA
The EXTRA_DIST variable is ignored when used in the FALSE conditional of a Makefile.am. This results in the `make dist` target omitting these files from the generated tarball unless CONFIG_USER is defined. This issue can be avoided by switching to use the dist_noinst_DATA variable which is handled as expected by autoconf. This change also adds support for --with-config=dist as an alias for --with-config=srpm and updates the GitHub workflows to use it. Reviewed-by: Ahelenia ZiemiaƄska <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #13459 Closes #13505
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index d6ca957ec..2e633041a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -25,6 +25,6 @@ dist_scripts_runfiles_DATA = \
%D%/runfiles/sunos.run
-EXTRA_DIST += $(addprefix %D%/,README.md)
+dist_noinst_DATA += %D%/README.md
SHELLCHECKSCRIPTS += $(shell find $(srcdir)/%D% -name '*.sh')