summaryrefslogtreecommitdiffstats
path: root/scripts/zpios-test/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2010-11-05 12:29:58 -0700
committerBrian Behlendorf <[email protected]>2010-11-08 14:03:36 -0800
commit8c3ab23f4be92a4e55f07f8c1bb467b851ed3e54 (patch)
tree7bf9f721af762af3c5ce5cd084c2f52ce63856af /scripts/zpios-test/Makefile.am
parenta8179b513904f4e11eb1299f70869d15ee577139 (diff)
Add lustre zpios-test workload
The lustre zpios-test simulates a reasonable lustre workload. It will create 128 threads, the same as a Lustre OSS, and then 4096 individual objects. Each objects is 16MiB in size and will be written/read in 1MiB from a random thread. This is fundamentally how we expect Lustre to behave for large IO intensive workloads.
Diffstat (limited to 'scripts/zpios-test/Makefile.am')
-rw-r--r--scripts/zpios-test/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/scripts/zpios-test/Makefile.am b/scripts/zpios-test/Makefile.am
index 07fd3e279..54935b4f8 100644
--- a/scripts/zpios-test/Makefile.am
+++ b/scripts/zpios-test/Makefile.am
@@ -1,15 +1,16 @@
pkglibexecdir = $(libexecdir)/@PACKAGE@/zpios-test
dist_pkglibexec_SCRIPTS = \
- $(top_srcdir)/scripts/zpios-test/16th-8192rc-4rs-1cs-4off.sh \
- $(top_srcdir)/scripts/zpios-test/1th-16rc-4rs-1cs-4off.sh \
- $(top_srcdir)/scripts/zpios-test/1x256th-65536rc-4rs-1cs-4off.sh \
- $(top_srcdir)/scripts/zpios-test/256th-65536rc-4rs-1cs-4off.sh \
- $(top_srcdir)/scripts/zpios-test/4th-1024rc-4rs-1cs-4off.sh \
- $(top_srcdir)/scripts/zpios-test/large.sh \
- $(top_srcdir)/scripts/zpios-test/large-thread-survey.sh \
- $(top_srcdir)/scripts/zpios-test/medium.sh \
- $(top_srcdir)/scripts/zpios-test/small.sh \
- $(top_srcdir)/scripts/zpios-test/tiny.sh
+ $(top_srcdir)/scripts/zpios-test/16th-8192rc-4rs-1cs-4off.sh \
+ $(top_srcdir)/scripts/zpios-test/1th-16rc-4rs-1cs-4off.sh \
+ $(top_srcdir)/scripts/zpios-test/1x256th-65536rc-4rs-1cs-4off.sh \
+ $(top_srcdir)/scripts/zpios-test/256th-65536rc-4rs-1cs-4off.sh \
+ $(top_srcdir)/scripts/zpios-test/4th-1024rc-4rs-1cs-4off.sh \
+ $(top_srcdir)/scripts/zpios-test/large.sh \
+ $(top_srcdir)/scripts/zpios-test/large-thread-survey.sh \
+ $(top_srcdir)/scripts/zpios-test/medium.sh \
+ $(top_srcdir)/scripts/zpios-test/small.sh \
+ $(top_srcdir)/scripts/zpios-test/tiny.sh \
+ $(top_srcdir)/scripts/zpios-test/lustre.sh
all:
@list='$(dist_pkglibexec_SCRIPTS)'; \