summaryrefslogtreecommitdiffstats
path: root/scripts/zpios-test/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2013-02-08 10:01:41 -0800
committerBrian Behlendorf <[email protected]>2013-03-06 15:46:40 -0800
commit48c028f5a5558894f8d94652050bc8e644760b9a (patch)
tree395c876cfa8d8e564ecbb7ef8110a96cb341c2aa /scripts/zpios-test/Makefile.am
parent0b4d1b5853791e1e447d74f0b229800d65b53071 (diff)
Replace libexecdir with datadir
According to the FHS. Testing scripts and examples which are all architecture independent should be installed in a subdirectory under /usr/share. http://www.pathname.com/fhs/2.2/fhs-4.11.html Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'scripts/zpios-test/Makefile.am')
-rw-r--r--scripts/zpios-test/Makefile.am22
1 files changed, 2 insertions, 20 deletions
diff --git a/scripts/zpios-test/Makefile.am b/scripts/zpios-test/Makefile.am
index 54935b4f8..c74e24f21 100644
--- a/scripts/zpios-test/Makefile.am
+++ b/scripts/zpios-test/Makefile.am
@@ -1,5 +1,5 @@
-pkglibexecdir = $(libexecdir)/@PACKAGE@/zpios-test
-dist_pkglibexec_SCRIPTS = \
+pkgdatatestdir = $(pkgdatadir)/zpios-test
+dist_pkgdatatest_SCRIPTS = \
$(top_srcdir)/scripts/zpios-test/16th-8192rc-4rs-1cs-4off.sh \
$(top_srcdir)/scripts/zpios-test/1th-16rc-4rs-1cs-4off.sh \
$(top_srcdir)/scripts/zpios-test/1x256th-65536rc-4rs-1cs-4off.sh \
@@ -11,21 +11,3 @@ dist_pkglibexec_SCRIPTS = \
$(top_srcdir)/scripts/zpios-test/small.sh \
$(top_srcdir)/scripts/zpios-test/tiny.sh \
$(top_srcdir)/scripts/zpios-test/lustre.sh
-
-all:
- @list='$(dist_pkglibexec_SCRIPTS)'; \
- for file in $$list; do \
- link=$$(basename $$file); \
- if [ ! -e $$link ]; then \
- $(LN_S) $$file $$link; \
- fi \
- done
-
-clean:
- @list='$(dist_pkglibexec_SCRIPTS)'; \
- for file in $$list; do \
- link=$$(basename $$file); \
- if [ -L $$link ]; then \
- $(RM) $$link; \
- fi \
- done