summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2013-02-08 10:01:41 -0800
committerBrian Behlendorf <[email protected]>2013-03-06 15:46:40 -0800
commit48c028f5a5558894f8d94652050bc8e644760b9a (patch)
tree395c876cfa8d8e564ecbb7ef8110a96cb341c2aa /scripts/Makefile.am
parent0b4d1b5853791e1e447d74f0b229800d65b53071 (diff)
Replace libexecdir with datadir
According to the FHS. Testing scripts and examples which are all architecture independent should be installed in a subdirectory under /usr/share. http://www.pathname.com/fhs/2.2/fhs-4.11.html Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am21
1 files changed, 1 insertions, 20 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index a96915938..80e9cd19a 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,7 +1,6 @@
SUBDIRS = zpool-config zpios-test zpios-profile
-pkglibexecdir = $(libexecdir)/@PACKAGE@
-dist_pkglibexec_SCRIPTS = \
+dist_pkgdata_SCRIPTS = \
$(top_builddir)/scripts/common.sh \
$(top_srcdir)/scripts/zconfig.sh \
$(top_srcdir)/scripts/zfault.sh \
@@ -18,24 +17,6 @@ ZFAULT=$(top_builddir)/scripts/zfault.sh
ZTEST=$(top_builddir)/cmd/ztest/ztest
ZPIOS_SANITY=$(top_builddir)/scripts/zpios-sanity.sh
-all:
- @list='$(dist_pkglibexec_SCRIPTS)'; \
- for file in $$list; do \
- link=$$(basename $$file); \
- if [ ! -e $$link ]; then \
- $(LN_S) $$file $$link; \
- fi \
- done
-
-clean:
- @list='$(dist_pkglibexec_SCRIPTS)'; \
- for file in $$list; do \
- link=$$(basename $$file); \
- if [ -L $$link ]; then \
- $(RM) $$link; \
- fi \
- done
-
check:
@$(ZFS) -u
@echo