summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2010-08-26 11:22:58 -0700
committerBrian Behlendorf <[email protected]>2010-08-31 13:41:27 -0700
commitc9c0d073da561bcbefbdf09c87fc75b227415619 (patch)
tree7daee55ae61526107f421de48171573fa5a15d28 /scripts/Makefile.am
parent40b84e7aec6392187722e61e5a4a853b530bf60f (diff)
Add build system
Add autoconf style build infrastructure to the ZFS tree. This includes autogen.sh, configure.ac, m4 macros, some scripts/*, and makefiles for all the core ZFS components.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
new file mode 100644
index 000000000..a1dfc3871
--- /dev/null
+++ b/scripts/Makefile.am
@@ -0,0 +1,29 @@
+pkglibexecdir = $(libexecdir)/@PACKAGE@
+nobase_pkglibexec_SCRIPTS = common.sh
+nobase_pkglibexec_SCRIPTS += zconfig.sh
+nobase_pkglibexec_SCRIPTS += zfs.sh
+nobase_pkglibexec_SCRIPTS += zpool-create.sh
+nobase_pkglibexec_SCRIPTS += zpool-config/*
+EXTRA_DIST = zfs-update.sh $(nobase_pkglibexec_SCRIPTS)
+
+ZFS=${top_srcdir}/scripts/zfs.sh
+ZCONFIG=${top_srcdir}/scripts/zconfig.sh
+ZTEST=${top_builddir}/cmd/ztest/ztest
+
+check:
+ @echo
+ @echo -n "===================================="
+ @echo -n " ZTEST "
+ @echo "===================================="
+ @echo
+ @$(ZFS)
+ @$(ZTEST) -V
+ @$(ZFS) -u
+ @echo
+ @echo
+ @echo -n "==================================="
+ @echo -n " ZCONFIG "
+ @echo "==================================="
+ @echo
+ @$(ZCONFIG)
+ @echo