aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2017-08-15 17:26:38 -0700
committerGitHub <[email protected]>2017-08-15 17:26:38 -0700
commitc8f9061fc714696a53cf4d14a4567f0a83dbf862 (patch)
tree42e8a39488899046384f9bb5e350032f438a3ae4 /scripts/Makefile.am
parent70322be8dc160f003fa95e034462ad625b325568 (diff)
Retire legacy test infrastructure
* Removed zpios kmod, utility, headers and man page. * Removed unused scripts zpios-profile/*, zpios-test/*, zpool-config/*, smb.sh, zpios-sanity.sh, zpios-survey.sh, zpios.sh, and zpool-create.sh. * Removed zfs-script-config.sh.in. When building 'make' generates a common.sh with in-tree path information from the common.sh.in template. This file and sourced by the test scripts and used for in-tree testing, it is not included in the packages. When building packages 'make install' uses the same template to create a new common.sh which is appropriate for the packaging. * Removed unused functions/variables from scripts/common.sh.in. Only minimal path information and configuration environment variables remain. * Removed unused scripts from scripts/ directory. * Remaining shell scripts in the scripts directory updated to cleanly pass shellcheck and added to checked scripts. * Renamed tests/test-runner/cmd/ to tests/test-runner/bin/ to match install location name. * Removed last traces of the --enable-debug-dmu-tx configure options which was retired some time ago. Reviewed-by: Giuseppe Di Natale <[email protected]> Signed-off-by: Brian Behlendorf <[email protected]> Closes #6509
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am70
1 files changed, 60 insertions, 10 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 74b8b31a5..7b2374a82 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -1,17 +1,67 @@
-SUBDIRS = zpool-config zpios-test zpios-profile
-
-EXTRA_DIST = dkms.mkconf dkms.postbuild kmodtool zfs2zol-patch.sed cstyle.pl
-
pkgdatadir = $(datadir)/@PACKAGE@
+
dist_pkgdata_SCRIPTS = \
- $(top_builddir)/scripts/common.sh \
$(top_srcdir)/scripts/zimport.sh \
$(top_srcdir)/scripts/zfs.sh \
$(top_srcdir)/scripts/zfs-tests.sh \
$(top_srcdir)/scripts/zloop.sh \
- $(top_srcdir)/scripts/zpool-create.sh \
- $(top_srcdir)/scripts/zpios.sh \
- $(top_srcdir)/scripts/zpios-sanity.sh \
- $(top_srcdir)/scripts/zpios-survey.sh \
- $(top_srcdir)/scripts/smb.sh \
$(top_srcdir)/scripts/zfs-helpers.sh
+
+EXTRA_DIST = \
+ common.sh.in \
+ commitcheck.sh \
+ dkms.mkconf \
+ dkms.postbuild \
+ kmodtool \
+ paxcheck.sh \
+ zfs2zol-patch.sed \
+ cstyle.pl
+
+define EXTRA_ENVIRONMENT
+
+# Only required for in-tree use
+export INTREE="yes"
+export GDB="/usr/bin/libtool --mode=execute gdb"
+export LDMOD=/sbin/insmod
+
+export CMD_DIR=@abs_top_builddir@/cmd
+export UDEV_RULE_DIR=@abs_top_builddir@/udev/rules.d
+export ZEDLET_ETC_DIR=$$CMD_DIR/zed/zed.d
+export ZEDLET_LIBEXEC_DIR=$$CMD_DIR/zed/zed.d
+export ZPOOL_SCRIPT_DIR=$$CMD_DIR/zpool/zpool.d
+export ZPOOL_SCRIPTS_PATH=$$CMD_DIR/zpool/zpool.d
+
+export INSTALL_UDEV_DIR=@udevdir@
+export INSTALL_UDEV_RULE_DIR=@udevruledir@
+export INSTALL_MOUNT_HELPER_DIR=@mounthelperdir@
+export INSTALL_SYSCONF_DIR=@sysconfdir@
+
+export KMOD_SPL=@SPL_OBJ@/module/spl/spl.ko
+export KMOD_SPLAT=@SPL_OBJ@/module/splat/splat.ko
+export KMOD_ZAVL=@abs_top_builddir@/module/avl/zavl.ko
+export KMOD_ZNVPAIR=@abs_top_builddir@/module/nvpair/znvpair.ko
+export KMOD_ZUNICODE=@abs_top_builddir@/module/unicode/zunicode.ko
+export KMOD_ZCOMMON=@abs_top_builddir@/module/zcommon/zcommon.ko
+export KMOD_ICP=@abs_top_builddir@/module/icp/icp.ko
+export KMOD_ZFS=@abs_top_builddir@/module/zfs/zfs.ko
+endef
+
+export EXTRA_ENVIRONMENT
+
+all-local:
+ -$(SED) -e '\|^export BIN_DIR=|s|$$|@abs_top_builddir@/bin|' \
+ -e '\|^export SBIN_DIR=|s|$$|@abs_top_builddir@/bin|' \
+ -e '\|^export ZTS_DIR=|s|$$|@abs_top_srcdir@/tests|' \
+ -e '\|^export SCRIPT_DIR=|s|$$|@abs_top_srcdir@/scripts|' \
+ common.sh.in >common.sh
+ -echo "$$EXTRA_ENVIRONMENT" >>common.sh
+
+clean-local:
+ -$(RM) common.sh
+
+install-data-hook:
+ -$(SED) -e '\|^export BIN_DIR=|s|$$|@bindir@|' \
+ -e '\|^export SBIN_DIR=|s|$$|@sbindir@|' \
+ -e '\|^export ZTS_DIR=|s|$$|@datadir@/@PACKAGE@|' \
+ -e '\|^export SCRIPT_DIR=|s|$$|@datadir@/@PACKAGE@|' \
+ common.sh.in >$(DESTDIR)$(datadir)/@PACKAGE@/common.sh