aboutsummaryrefslogtreecommitdiffstats
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorBrian Behlendorf <[email protected]>2010-08-26 11:58:00 -0700
committerBrian Behlendorf <[email protected]>2010-08-31 13:42:01 -0700
commit302ef1517e5769cbe6a12d94c89f44a90721bfd4 (patch)
treedeb845a6a474955769d58062ea39cc19334cbcff /scripts/Makefile.am
parent9b020fd97a3dc449a94baec028b30b1fe3c2d5bc (diff)
Add linux zpios support
Linux kernel implementation of PIOS test app. Signed-off-by: Brian Behlendorf <[email protected]>
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index a1dfc3871..ed6e5028f 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -4,11 +4,17 @@ nobase_pkglibexec_SCRIPTS += zconfig.sh
nobase_pkglibexec_SCRIPTS += zfs.sh
nobase_pkglibexec_SCRIPTS += zpool-create.sh
nobase_pkglibexec_SCRIPTS += zpool-config/*
+nobase_pkglibexec_SCRIPTS += zpios.sh
+nobase_pkglibexec_SCRIPTS += zpios-sanity.sh
+nobase_pkglibexec_SCRIPTS += zpios-survey.sh
+nobase_pkglibexec_SCRIPTS += zpios-test/*
+nobase_pkglibexec_SCRIPTS += zpios-profile/*
EXTRA_DIST = zfs-update.sh $(nobase_pkglibexec_SCRIPTS)
ZFS=${top_srcdir}/scripts/zfs.sh
ZCONFIG=${top_srcdir}/scripts/zconfig.sh
ZTEST=${top_builddir}/cmd/ztest/ztest
+ZPIOS_SANITY=${top_srcdir}/scripts/zpios-sanity.sh
check:
@echo
@@ -27,3 +33,11 @@ check:
@echo
@$(ZCONFIG)
@echo
+ @echo -n "===================================="
+ @echo -n " ZPIOS "
+ @echo "===================================="
+ @echo
+ @$(ZFS)
+ @$(ZPIOS_SANITY)
+ @$(ZFS) -u
+ @echo