aboutsummaryrefslogtreecommitdiffstats
path: root/man/man8/Makefile.am
diff options
context:
space:
mode:
authorAntonio Russo <[email protected]>2018-05-11 15:44:14 -0400
committerBrian Behlendorf <[email protected]>2018-05-11 12:44:14 -0700
commit68fded814692c6a7fa7ca1f584a34a92aaa279af (patch)
treef0201a8caaf0050745b92761f0b65eaa699296c3 /man/man8/Makefile.am
parent29badadd4e3af86975bcaa23acca0e939f954af2 (diff)
Add canonical mount options zfs-mount-generator
lib/libzfs/libzfs_mount.c:zfs_add_options provides the canonical mount options used by a `zfs mount` command. Because we cannot call `zfs mount` directly from a systemd.mount unit, we mirror that logic in zfs-mount-generator. The zed script is updated to cache these properties as well. Include a mini-tutorial in the manual page, properly substitute configuration paths in zfs-mount-generator.8.in, and standardize the Makefile. Reviewed-by: Brian Behlendorf <[email protected]> Reviewed-by: Richard Laager <[email protected]> Signed-off-by: Antonio Russo <[email protected]> Closes #7453
Diffstat (limited to 'man/man8/Makefile.am')
-rw-r--r--man/man8/Makefile.am25
1 files changed, 9 insertions, 16 deletions
diff --git a/man/man8/Makefile.am b/man/man8/Makefile.am
index b6408ddf2..153cd518f 100644
--- a/man/man8/Makefile.am
+++ b/man/man8/Makefile.am
@@ -4,7 +4,6 @@ dist_man_MANS = \
vdev_id.8 \
zdb.8 \
zfs.8 \
- zfs-mount-generator.8 \
zfs-program.8 \
zgenhostid.8 \
zinject.8 \
@@ -12,24 +11,18 @@ dist_man_MANS = \
zstreamdump.8
nodist_man_MANS = \
- zed.8
+ zed.8 \
+ zfs-mount-generator.8
EXTRA_DIST = \
- zed.8.in
+ zed.8.in \
+ zfs-mount-generator.8.in
-zed.8: $(srcdir)/zed.8.in
-
-do_subst = $(SED) \
- -e 's|@libexecdir[@]|$(libexecdir)|g' \
- -e 's|@runstatedir[@]|$(runstatedir)|g' \
- -e 's|@sysconfdir[@]|$(sysconfdir)|g'
-
-$(nodist_man_MANS): Makefile
- srcdir=''; \
- test -f ./[email protected] || srcdir=$(srcdir)/; \
- $(do_subst) $${srcdir}[email protected] >[email protected]
+$(nodist_man_MANS): %: %.in
+ -$(SED) -e 's,@libexecdir\@,$(libexecdir),g' \
+ -e 's,@runstatedir\@,$(runstatedir),g' \
+ -e 's,@sysconfdir\@,$(sysconfdir),g' \
+ $< >'$@'
install-data-local:
$(INSTALL) -d -m 0755 "$(DESTDIR)$(mandir)/man8"