aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libzutil/Makefile.am
diff options
context:
space:
mode:
authorMatthew Macy <[email protected]>2019-11-12 10:40:39 -0800
committerBrian Behlendorf <[email protected]>2019-11-12 10:40:39 -0800
commit1f2f46be9576964c90ca25805c9741d56bbaccdf (patch)
treec97f1f0f4d02df788bb4e16350aed7e0c577304c /lib/libzutil/Makefile.am
parent066e825221012e1e81ccf46b0448772bdd7e5483 (diff)
Add wrapper stub for zfs_cmd ioctl to libzpool
FreeBSD needs a wrapper for handling zfs_cmd ioctls. In libzfs this is handled by zfs_ioctl. However, here we need to wrap the call directly. Reviewed-by: Allan Jude <[email protected]> Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Matt Macy <[email protected]> Closes #9511
Diffstat (limited to 'lib/libzutil/Makefile.am')
-rw-r--r--lib/libzutil/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/libzutil/Makefile.am b/lib/libzutil/Makefile.am
index 8b53c374e..e5c6a340d 100644
--- a/lib/libzutil/Makefile.am
+++ b/lib/libzutil/Makefile.am
@@ -17,7 +17,8 @@ USER_C = \
if BUILD_LINUX
USER_C += \
os/linux/zutil_device_path_os.c \
- os/linux/zutil_import_os.c
+ os/linux/zutil_import_os.c \
+ os/linux/zutil_compat.c
endif
nodist_libzutil_la_SOURCES = $(USER_C)