summaryrefslogtreecommitdiffstats
path: root/lib/libzfsbootenv/Makefile.am
diff options
context:
space:
mode:
authorAntonio Russo <[email protected]>2020-11-14 21:35:31 -0700
committerBrian Behlendorf <[email protected]>2020-11-17 09:18:52 -0800
commit14c34c3d49319a0fea937d54167602c43ff9d93f (patch)
tree7ca38e771ad64cb64fcc1817e01a0029fe4f7639 /lib/libzfsbootenv/Makefile.am
parente6c59cd171bf141eae232db2f4c33ff79d5862c3 (diff)
Library ABI tracking with abigail
Provide two make targets: checkabi and storeabi. storeabi uses libabigail to generate a reference copy of the ABI for the public libraries. checkabi compares such a reference to the compiled version, failing if they are not compatible. No ABI is generated for libzpool.so, it is only used by ztest and zdb and not external consumers. Co-authored-by: Brian Behlendorf <[email protected]> Signed-off-by: Antonio Russo <[email protected]> Closes #11144
Diffstat (limited to 'lib/libzfsbootenv/Makefile.am')
-rw-r--r--lib/libzfsbootenv/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/lib/libzfsbootenv/Makefile.am b/lib/libzfsbootenv/Makefile.am
index 6b9a8f013..354be3efa 100644
--- a/lib/libzfsbootenv/Makefile.am
+++ b/lib/libzfsbootenv/Makefile.am
@@ -1,9 +1,12 @@
include $(top_srcdir)/config/Rules.am
+PHONY =
pkgconfig_DATA = libzfsbootenv.pc
lib_LTLIBRARIES = libzfsbootenv.la
+include $(top_srcdir)/config/Abigail.am
+
if BUILD_FREEBSD
DEFAULT_INCLUDES += -I$(top_srcdir)/include/os/freebsd/zfs
endif