aboutsummaryrefslogtreecommitdiffstats
path: root/lib/libzfs_core/Makefile.am
diff options
context:
space:
mode:
authorArvind Sankar <[email protected]>2020-07-05 21:08:40 -0400
committerBrian Behlendorf <[email protected]>2020-07-10 14:26:12 -0700
commit1537105a8cfecb227a2925a7889cd662224b7968 (patch)
tree0fe488b7e9bba4512318e1e7f54f17c54e045d85 /lib/libzfs_core/Makefile.am
parent4d61ade1a317606dc899e38b516410a0c2fdae0e (diff)
Add config.rpath for AM_GNU_GETTEXT
Commit e8864b1b28c2 ("config: libintl/libiconv for gettext() detection") added an empty config.rpath with a comment that the real one doesn't work with libtool. However, an empty config.rpath doesn't really work: eg. on FreeBSD, where libintl is in /usr/local/lib, configure thinks that gettext doesn't exist and NLS should be disabled, which currently isn't supported in the source, and hence requires manual workaround to directly link -lintl without relying on configure. config.rpath is essential to let it be detected either in --prefix or using --with-libintl-prefix. I also don't see the mentioned issue with libtool flags applied to compilation, it seems to work fine to pass LTLIBINTL to libtool. It's unnecessary to include LTLIBICONV as the configure test will automatically append that to LTLIBINTL if it is necessary to link with libiconv. Reviewed-by: Brian Behlendorf <[email protected]> Signed-off-by: Arvind Sankar <[email protected]> Closes #10538
Diffstat (limited to 'lib/libzfs_core/Makefile.am')
-rw-r--r--lib/libzfs_core/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/lib/libzfs_core/Makefile.am b/lib/libzfs_core/Makefile.am
index 44940e915..39731f312 100644
--- a/lib/libzfs_core/Makefile.am
+++ b/lib/libzfs_core/Makefile.am
@@ -13,6 +13,8 @@ libzfs_core_la_LIBADD = \
$(top_builddir)/lib/libzutil/libzutil.la \
$(top_builddir)/lib/libnvpair/libnvpair.la
+libzfs_core_la_LIBADD += $(LTLIBINTL)
+
libzfs_core_la_LDFLAGS = -pthread
if BUILD_FREEBSD